Menggabungkan Konfigurasi Routing Protocol Eigrp Dengan Ospf

Pada peluang kali ini saya akan share wacana konfigurasi memadukan routing protocol EIGRP dengan OSPF atau biasa disebut dengan Redistributing EIGRP to OSPF. Untuk kali ini saya menggunakan simulator Packet Tracer.
Untuk topologi dari jaringan saya buat menyerupai berikut,


Apabila Anda kurang terperinci dengan gambar topologi diatas jangan khawatir, file .pkt dari topologi sanggup di download pada bab simpulan dari postingan ini.

Tujuan

  • Konfigurasi Routing EIGRP 100
  • Konfigurasi Routing OSPF Area 0
  • Menggabungkan EIGRP ke OSPF dengan redistribute
Langkah Konfigurasi

Untuk ip address telah diberikan dan disetting, tinggal mengkonfigurasikan routing protokolnya saja.

Konfigurasi Routing EIGRP 100

#R1
R1(config)#router eigrp 100
R1(config-router)#network 12.12.12.0 0.0.0.255
R1(config-router)#network 172.16.0.0 0.0.0.255
R1(config-router)# network 172.16.1.0 0.0.0.255
R1(config-router)#network 172.16.2.0 0.0.0.255
R1(config-router)#network 192.168.1.0 0.0.0.255
R1(config-router)#no auto-summary
R1(config-router)#passive-interface FastEthernet0/0

#R2
R2(config)#router eigrp 100
R2(config-router)#network 12.12.12.0 0.0.0.255
R2(config-router)#network 23.23.23.0 0.0.0.255
R2(config-router)#network 172.16.3.0 0.0.0.255
R2(config-router)#network 172.16.4.0 0.0.0.255
R2(config-router)#network 172.16.5.0 0.0.0.255
R2(config-router)#network 192.168.2.0 0.0.0.255
R2(config-router)#no auto-summary
R2(config-router)#passive-interface FastEthernet0/0

#R3
R3(config)#router eigrp 100
R3(config-router)#network 23.23.23.0 0.0.0.255
R3(config-router)#network 36.36.36.0 0.0.0.255
R3(config-router)#network 172.16.6.0 0.0.0.255
R3(config-router)#network 172.16.7.0 0.0.0.255
R3(config-router)#network 172.16.8.0 0.0.0.255
R3(config-router)#network 192.168.3.0 0.0.0.255
R3(config-router)#network 37.37.37.0 0.0.0.255
R3(config-router)#no auto-summary
R3(config-router)#passive-interface FastEthernet0/0

#R4
R4(config)#router eigrp 100
R4(config-router)#network 45.45.45.0 0.0.0.255
R4(config-router)#network 172.16.9.0 0.0.0.255
R4(config-router)#network 172.16.10.0 0.0.0.255
R4(config-router)#network 172.16.11.0 0.0.0.255
R4(config-router)#network 192.168.4.0 0.0.0.255
R4(config-router)#no auto-summary
R4(config-router)#passive-interface FastEthernet0/0

#R5
R5(config)#router eigrp 100
R5(config-router)#network 45.45.45.0 0.0.0.255
R5(config-router)#network 56.56.56.0 0.0.0.255
R5(config-router)#network 172.16.12.0 0.0.0.255
R5(config-router)#network 172.16.13.0 0.0.0.255
R5(config-router)#network 172.16.14.0 0.0.0.255
R5(config-router)#network 192.168.5.0
R5(config-router)#no auto-summary
R5(config-router)#passive-interface FastEthernet0/0

#R6
R6(config)#router eigrp 100
R6(config-router)#network 172.16.15.0 0.0.0.255
R6(config-router)#network 172.16.16.0 0.0.0.255
R6(config-router)#network 172.16.17.0 0.0.0.255
R6(config-router)#network 192.168.6.0 0.0.0.255
R6(config-router)#network 56.56.56.0 0.0.0.255
R6(config-router)#network 36.36.36.0 0.0.0.255
R6(config-router)#network 67.67.67.0 0.0.0.255
R6(config-router)#no auto-summary
R6(config-router)#passive-interface FastEthernet0/0

#R7
R7(config)#router eigrp 100
R7(config-router)#network 37.37.37.0 0.0.0.255
R7(config-router)#network 67.67.67.0 0.0.0.255
R7(config-router)#no auto-summary

Konfigurasi Routing OSPF Area 0

#R8
R8(config)#router ospf 1
R8(config-router)#network 89.89.89.0 0.0.0.255 area 0
R8(config-router)#network 82.82.82.0 0.0.0.255 area 0
R8(config-router)#network 10.10.10.0 0.0.0.3 area 0

#R9
R9(config)#router ospf 1
R9(config-router)#network 90.90.90.0 0.0.0.255 area 0
R9(config-router)#network 92.92.92.0 0.0.0.255 area 0
R9(config-router)#network 192.168.9.0 0.0.0.255 area 0
R9(config-router)#network 89.89.89.0 0.0.0.255 area 0
R9(config-router)#passive-interface FastEthernet0/0

#R10
R10(config)#router ospf 1
R10(config-router)#network 90.90.90.0 0.0.0.255 area 0
R10(config-router)#network 101.101.101.0 0.0.0.255 area 0
R10(config-router)#network 192.168.10.0 0.0.0.255 area 0
R10(config-router)#passive-interface FastEthernet0/0
 
#R11
R11(config)#router ospf 1
R11(config-router)#network 101.101.101.0 0.0.0.255 area 0
R11(config-router)#network 192.168.11.0 0.0.0.255 area 0
R11(config-router)#passive-interface FastEthernet0/0

#R12
R12(config)#router ospf 1
R12(config-router)#network 92.92.92.0 0.0.0.255 area 0
R12(config-router)#network 123.123.123.0 0.0.0.255 area 0
R12(config-router)#network 192.168.12.0 0.0.0.255 area 0
R12(config-router)#network 82.82.82.0 0.0.0.255 area 0
R12(config-router)#passive-interface FastEthernet0/0

#R13
R13(config)#router ospf 1
R13(config-router)#network 123.123.123.0 0.0.0.255 area 0
R13(config-router)#network 134.134.134.0 0.0.0.255 area 0
R13(config-router)#network 192.168.13.0 0.0.0.255 area 0
R13(config-router)#passive-interface FastEthernet0/0

#R14
R14(config)#router ospf 1
R14(config-router)#network 134.134.134.0 0.0.0.255 area 0
R14(config-router)#network 192.168.14.0 0.0.0.255 area 0
R14(config-router)#passive-interface FastEthernet0/0

Konfigurasi Redistributing EIGRP ke OSPF

Untuk konfigurasi redistribute sanggup dijalankan pada Router 7 atau Router 8. Karena disini topiknya redistribute EIGRP ke OSPF maka konfigurasi dijalankan di Router 7. Alternatif lain sanggup dijalankan di Router 8 untuk menjalankan redistribute OSPF ke EIGRP.

R7(config)#router ospf 1
R7(config-router)#network 10.10.10.0 0.0.0.3 area 0
R7(config-router)#redistribute eigrp 100 subnets
R7(config-router)#exit
R7(config)#router eigrp 100
R7(config-router)#redistribute ospf 1 metric 1 1 1 1 1

Verifikasi

Untuk verifikasi sanggup dijalankan di tiap router dengan menjalankan perintah "show ip route"

File dari Lab pada postingan ini sanggup di download disini.

Related : Menggabungkan Konfigurasi Routing Protocol Eigrp Dengan Ospf

0 Komentar untuk "Menggabungkan Konfigurasi Routing Protocol Eigrp Dengan Ospf"