Konfigurasi Ospf Single Area Di Gns3

Pada aktifitas lab kali ini saya menggunakan GNS3. Anda juga sanggup menggunakan Packet Tracer untuk ngelab OSPF Single Area ini. :)
Berikut topologi untuk konfigurasi OSPF Single Area


Tujuan
  • Mensetting routing protocol OSPF Singe-Area di R1 dan R2
  • Mensetting interface loopback di R1 dan R2
Langkah Konfigurasi

IP address S0/0 R1 = 12.12.12.1/30
IP address S0/0 R2 = 12.12.12.2/30

R1#conf t
R1(config)#int s0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.252
R1(config-if)#clock rate 2000000
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#int lo0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#exit
R1(config)#

R2#conf t
R2(config)#int s0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int lo0
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#exit
R2(config)#

Interface loopback pada lab ini berfungsi selaku virtual subnet. Sehingga seolah-olah kita memiliki 1 subnet yang dihubungkan lewat koneksi serial antara R1 dan R2. Loopback sungguh berharga untuk nge-lab bila resource computer kita minimal, sehingga tidak perlu menggunakan jumlah router yang banyak.

Pada semua design network OSPF yang bagus, backbone area lazimnya disetting selaku area 0. Maka, area 0 sering disebut juga selaku backbone area, alasannya berfungsi untuk mengkoneksikan antar area.

Untuk mensetting OSPF routing protocol gunakan command router ospf process-id. Proses ID cuma berlaku untuk local router, sehingga tidak kokoh untuk router lain. Proses ID boleh beda antar router dan dalam satu router sanggup melaksanakan multiple proses ID. Setelah itu setting dengan sub-command network address wildcard-mask area area-id. Tentukan network address yang hendak diadvertised menggunakan OSPF. Dalam satu area-id, router mesti memiliki area-id yang serupa sehingga sanggup membentuk adjacency.

Konfigurasi routing OSPF

R1(config)#router ospf 1
R1(config-router)#network 12.12.12.0 0.0.0.3 area 0
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0

R2(config)#router ospf 1
R2(config-router)#network 12.12.12.0 0.0.0.3 area 0
R2(config-router)#network 192.168.2.0 0.0.0.255 area 0

Wildcard mask 0.0.0.0 artinya mesti match. Wildcard mask 0.0.0.3 artinya cuma 3 oktet yang match dan octet keempat ignored. Contoh untuk network 12.12.12.0 0.0.0.3 area 0 artinya 12.12.12.1 hingga 12.12.12.2. Pada wildcard mask lain misal 0.0.0.255, Anda sanggup mengkonfigurasi IP address apa saja yang berada pada range 192.168.1.1 – 192.168.1.254 untuk di area 0 pada interface s0/0 R1.

Karena pada lab ini menggunakan OSPF Single-Area yakni area 0, maka semua router mesti memiliki area yang serupa mudah-mudahan sanggup membentuk adjacency sehingga semua network sanggup berkomunikasi. Untuk area yang serupa lazimnya disebut juga Intra Area, sedangkan untuk area yang berlainan Inter Area.

Verifikasi

Kita lihat tabel routing pada R1 dengan mengetikkan perintah "show ip route".


Untuk OSPF kodenya O. Lihat pada isyarat O, network address 192.168.2.0 ada di R2. Untuk menuju ke network tersebut dari R1 menggunakan jalur 12.12.12.2. IP 12.12.12.2 ialah IP address s0/0 R2. “via” artinya gateway yang mau dilewati / lewat mana. Simplenya untuk menuju ke network 192.168.2.0 lewat 12.12.12.2.

Untuk output mudah-mudahan spesifik routing OSPF saja yang ditampilkan sanggup menggunakan command dibawah : "show ip route ospf"

Metric OSPF pada Lab ini yakni 65, sedangkan Administrative Distance OSPF = 110. Dapat dilihat pada baris berikut:

O 192.168.2.1 [110/65] via 12.12.12.2, 00:00:56, Serial0/0

R1 secara dinamis mempelajari remote network pada R2 lewat next hop address 12.12.12.2 dan outbound interface Serial 0/0. OSPF membentuk neighborship dengan adjacent router dengan melaksanakan pertukaran Paket Type 1 (Hello). Berikut ini keadaan yang mesti dipenuhi oleh dua router untuk membentuk neighbor:
  • Masing-masing router mesti berada pada subnet yang serupa dan menggunakan subnet mask yang sama
  • Masing-masing router mesti memiliki hello dan dead intervals yang sama
    • Hello interval mengidentifikasikan berapa frekuensi neighbor router melaksanakan pertukaran hello packet
    • Dead interval mengidentifikasikan jumlah waktu yang diijinkan tanpa mengantarkan hello packet.
    • Note: bila secara periodic hello packet tidak diterima dalam rentang waktu dead interval, maka router mengasumsikan bahwa neighbor router sudah offline.
  • Masing-masing router mesti menggunakan area yang sama
  • Jika autentikasi dibutuhkan, masing-masing router mesti menyanggupi requirement autentikasi
Adjacent router yakni router yang menjadi tetangga (neighbor) dan akan melaksanakan sharing atau pertukaran gunjingan database yang dimiliki.

Ping dari S0/0 R1 ke Interface Loopback 2 di R2 :

Related : Konfigurasi Ospf Single Area Di Gns3

0 Komentar untuk "Konfigurasi Ospf Single Area Di Gns3"